自学内容网 自学内容网

L2-004 这是二叉搜索树吗?

一棵二叉搜索树可被递归地定义为具有下列性质的二叉树:对于任一结点,

  • 其左子树中所有结点的键值小于该结点的键值;
  • 其右子树中所有结点的键值大于等于该结点的键值;
  • 其左右子树都是二叉搜索树。

所谓二叉搜索树的“镜像”,即将所有结点的左右子树对换位置后所得到的树。

给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。

输入格式:

输入的第一行给出正整数 N(≤1000)。随后一行给出 N 个整数键值,其间以空格分隔。

输出格式:

如果输入序列是对一棵二叉搜索树或其镜像进行前序遍历的结果,则首先在一行中输出 YES ,然后在下一行输出该树后序遍历的结果。数字间有 1 个空格,一行的首尾不得有多余空格。若答案是否,则输出 NO

输入样例 1:

7
8 6 5 7 10 8 11

输出样例 1:

YES
5 7 6 8 11 10 8

输入样例 2:

7
8 10 11 8 6 7 5

输出样例 2:

YES
11 8 10 7 5 6 8

输入样例 3:

7
8 6 8 5 10 9 11

输出样例 3:

NO

 solution:
 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
vector<int>a;
vector<int>pre,premir,post,postmir;
#define null NULL
struct node
{
int val;
node *left;
node *right;
};
void build(node* &t,int x)
{
if(t==null)
{
t=new node();
t->val=x;
t->left=null;
t->right=null;
return;
}
if(t->val<=x)build(t->right,x);
else build(t->left,x);
}
void preorder(node *t)
{
if(t==null)return;
pre.push_back(t->val);
preorder(t->left);
preorder(t->right);
}
void premirorder(node *t)
{
if(t==null)return;
premir.push_back(t->val);
premirorder(t->right);
premirorder(t->left);
}
void postorder(node *t)
{
if(t==null)return;
postorder(t->left);
postorder(t->right);
post.push_back(t->val);
}
void postmirorder(node *t)
{
if(t==null)return;
postmirorder(t->right);
postmirorder(t->left);
postmir.push_back(t->val);
}
int main()
{
int n;cin>>n;
node *root=null;
for(int i=0;i<n;i++)
{
int x;cin>>x;
a.push_back(x);
build(root,x);
}
premirorder(root);
preorder(root);
if(a==pre)
{
cout<<"YES"<<endl;
postorder(root);
for(int i=0;i<post.size();i++)
{
if(i)cout<<' ';
cout<<post[i];
}
cout<<endl;
}
else if(a==premir)
{
cout<<"YES"<<endl;
postmirorder(root);
for(int i=0;i<postmir.size();i++)
{
if(i)cout<<' ';
cout<<postmir[i];
}
cout<<endl;
}
else cout<<"NO"<<endl;
}


原文地址:https://blog.csdn.net/flyidj/article/details/142638829

免责声明:本站文章内容转载自网络资源,如本站内容侵犯了原著者的合法权益,可联系本站删除。更多内容请关注自学内容网(zxcms.com)!