自学内容网 自学内容网

数据结构,问题 B: 反向输出

题目描述

模拟栈将输入的一串数字 ,反着输出。

输入

输入一行,一行内输入n个整数,以空格间隔(n<=50,题目保证输入的整数在int范围内)

输出

一行内倒着输出这一串整数,以空格间隔。

样例输入 复制
1 2 3 4 5 6 7 8
样例输出 复制
8 7 6 5 4 3 2 1

 

#include<bits/stdc++.h>
using namespace std;
 
stack<int>st;
 
int main(){
    int n;
    while(cin >> n){
        st.push(n);
    }
    while(!st.empty()){
        cout << st.top() << ' ';
        st.pop();
    }
    return 0;
}


原文地址:https://blog.csdn.net/nick_912912/article/details/143419025

免责声明:本站文章内容转载自网络资源,如本站内容侵犯了原著者的合法权益,可联系本站删除。更多内容请关注自学内容网(zxcms.com)!