6-1 jmu-Java-04面向对象进阶-01-接口-匿名内部类ActionListener
分数 10
全屏浏览
切换布局
作者 郑如滨
单位 集美大学
已有MyStarter
类(你无需编写,直接使用),其具有:
构造函数:public MyStarter(ActionListener ac)
方法:start()
启动任务
###main方法执行流程:
- 输入整数n和字符串x。
- 创建MyStarter对象。该对象的任务为输出n个x字符串,并在循环结束后,使用如下代码
打印一些标识信息。 注意:MyStarter类的构造函数System.out.println(this.getClass().getName()); System.out.println(Arrays.toString(this.getClass().getInterfaces()));
public MyStarter(ActionListener ac)
要接收ActionListener
类型的对象,我们需要建立这个对象并在该对象相应的方法中编写相关功能代码。
最后:调用MyStarter对象的start
方法启动任务。
裁判测试程序:
public static void main(String[] args) {
MyStarter starter;
//这边写上你的代码
starter.start(); sc.close();
}
输入样例:
3
a
输出样例:
a
a
a
//此处有两行标识信息
代码区:
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
String x = sc.next();
// 创建一个实现了ActionListener接口的匿名类
ActionListener actionListener = new ActionListener() {
@Override
public void actionPerformed(ActionEvent e) {
// 输出n个x字符串
for (int i = 0; i < n; i++) {
System.out.println(x);
}
// 打印标识信息
System.out.println(this.getClass().getName());
System.out.println(Arrays.toString(this.getClass().getInterfaces()));
}
};
// 创建MyStarter对象
starter = new MyStarter(actionListener);
原文地址:https://blog.csdn.net/GZH_mxjx/article/details/142499551
免责声明:本站文章内容转载自网络资源,如本站内容侵犯了原著者的合法权益,可联系本站删除。更多内容请关注自学内容网(zxcms.com)!